Bulk Uploads: Incorrect Time Format

What is the correct format for time entry. I used hh:mm:ss and it is incorrect.

That depends on what you have set on your forms.

Also, be sure there are not any spaces or hidden chars (from copying/pasting from Word or similar)

Thank you for your response. I don’t change the time format, it is the default Hours:Minutes:Seconds. No space or hidden char as I know of, because I just reuploaded the CSV using bulk editing feature.

image

Works for us. If you tell us your project name we can double check

This is our project name: https://five.epicollect.net/project/ipb-ubs-kuantitatif-d. The time entry question is the third from the back. Thank you

All is good for us again.
You might send us the failing rows .csv file by email (five.epicollect.net@gmail.com) so we could try with that file.

It is OK now, strange. Anyway, thank you for your assistance.

1 Like

Hello, complete novice here, I seem to have the same problem. After chasing out other silly mistakes, I’m left with this issue. My date format is set in ‘forms’ to HH:MM:SS(24hr) and I’m converting the time in excel to seemingly the same format, exporting as a csv then trying the upload. Put in a time zone answer, no change. Added varying numbers of decimal places after the seconds, no different. Etc.

Please paste here a sample of the data you are trying to upload along with your project name so we can try it on our side. You could send us a csv file at five.epicollect.net@gmail.com as well.

Be aware Excel might add some hidden chars for formatting, that could be the issue

Thanks for this. Mysteriously, my times were OK this time, but it wanted date as d/m/y not y/m/d. And now my copy of Libre Calc (not-quite-excel) has failed, so I started knife-and-forking it in WordPad, which gave me the chance to chop off a number of ‘dummy’ lines at the bottom, reducing the frustration of the wait… A number of ‘required fields’ with ‘No’ added and the like and I’m in business… Real data at last in the Friends of the Lower Wye repository. On to the next set of data to format and upload…

The date is not required for a TIME question, we are not sure what “ but it wanted date as d/m/y not y/m/d” refers to.

To explain that last… in the bulk upload each line contains both a date and a time. The time format had been failing. Somehow (overnight, with no known intervention from me!) it stopped failing. But then there remained such trivial and fixable issues as that its preferred date format was dd/mm/yyyy not yyyy/mm/dd (please excuse my hasty abbreviation of yyyy/mm/dd via year/month/day to y/m/d etc.!)

So that was last month…

This month I’m back to it not uploading due to time format issues once more. A time like 10:30:00 is not accepted. Error: “Date/time format incorrect”. I’ve tried forcing removal of any fancy spreadsheet formatting by saving it from notepad, but no joy. (My spreadsheet program on this machine is Libre Calc).

Example not uploading:
file_start/
,
ec5_uuid,created_at,uploaded_at,title,1_Initials,2_Sample_site_ID,lat_3_Sample_site_locati,long_3_Sample_site_locati,accuracy_3_Sample_site_locati,UTM_Northing_3_Sample_site_locati,UTM_Easting_3_Sample_site_locati,UTM_Zone_3_Sample_site_locati,5_Date_sample_taken,6_Time_sample_taken,7_Turbidity_NTU,8_Electrical_conduct,9_Temperature_c,10_Nitrate_test_stri,11_Nitrite_test_stri,12_How_are_you_measu,13_Phosphate_test_st,14_Phosphate_Hanna_C,15_Fixed_point_photo,16_Any_other_comment,18_Rainfall_in_the_l,19_Flow_conditions,20_Relative_water_le,21_Fixed_point_water,23_Can_you_see_an_al,24_If_YES_how_big_is,25_Can_you_see_any_o,26_If_YES_please_des,27_Please_take_a_pho
,
,2021-11-10T10:30:00.000Z,JH,63 Wye at Redbrook (Steps by green),51.782478,-2.674231,4,10/11/2021,10:30:00,256,11.7,2,0.3,0.1,No rain,Steady (walking pace),Low,No,No,
,
,2021-11-10T10:30:00.000Z,JH,“17 Bigwell Fishery, Redbrook”,51.782417,-2.666057,4,10/11/2021,10:30:00,517,12,0,3.0,0,No rain,Steady (walking pace),Low,No,No,
,
,2021-11-17T10:30:00.000Z,JH,63 Wye at Redbrook (Steps by green),51.782478,-2.674231,4,17/11/2021,10:30:00,281,10.5,1,1.0,0.07,No rain,Steady (walking pace),Low,1.78,No,No,
,
,
end,
/file_end

OK, with more messing around, I found that there seems to be a right way to force the time cells to adopt an acceptable date format… select cell(s), format>cell>time>hh/mm/ss etc. -if right click to start the process doesn’t do it, use the menu from the ribbon… Job done.

1 Like

I found the solution! The Windows date format was set to d/mm/yyyy, in my epicollet application the day/month/year format was correct, but it turns out that epicollet accepts the dd/mm/yyyy format.

with two “dd” → "Incorrect (Windows) d/mm/aaaa → correct (Windows) dd/mm/aaaa

I found the solution! The Windows date format was set to d/mm/yyyy, in my epicollet application the day/month/year format was correct, but it turns out that epicollet accepts the dd/mm/yyyy format.

with two “dd” → "Incorrect (Windows) d/mm/aaaa → correct (Windows) dd/mm/aaaa

Att Deisman Bedón Colombian

Great! We are glad the issue is solved.

For the records, dd for day represents the day of the month (1-31), while d is the day of the week (1-7) according to the ISO 8601 standard →

ISO 8601 - Wikipedia.

Epicollect5 does not support d, only dd.