Control lost over the form

I created a form as Gross survey, it was a public form. Initial 3 days I was able to view/edit the form as the creator, on 4th day it stopped showing in my projects when i try to access it, it says you need permission. I did not give rights to anyone as a creator or manager and now I can’t access the project and data that was collected. Please help.

Please provide the name of the project so we can look into it.

Also, make sure you are logged in with the same email, as the project ownership is linked to the email address.

Name of the Project - Gross Survey
Details - To screen ANC, under 5

I am trying to login from the same account

That project was created with a doctorsforyou.org email domain, have you tried that?

Dear Epicollect team, i am facing similar kind of problem.

I have created the form and while editing the Form builder the repositioning of questionnaire hanged and tried to save the project but after reloading, the same page i can see now it as blank. I have lost my questionnaire all total. Please guide for recovering it