Entries not loading

I’ve been using Epicollect lately on a Samsung Galaxy S6 Tab for field data collecting.
However, I have encountered an error twice when I try to leave the project after everything has been saved. The screen goes white, with just a window saying “Loading entries”, but nothing actually loads, even after several hours. Neither exiting or closing the app has been effective, as the same screen appears once I reopen the app. Only reinstalling the app has solved this, but the data cannot be recovered, apparently (as they were not uploaded to the cloud).
Is there any way to solve this while not losing the recent entries?

Thanks in advance.


if you force close the app, it starts from the home screen again.

To preserve data across re-installs, try to enable the App Data backup option of your Google Account

and trigger a backup manually before uninstalling Epicollect5

Hello again,

I am afraid I wasn´t able to retrieve the lost data. I tried to back up the tablet, but Epicollect data were not included somehow.
Since I had another tablet (iPad Pro 11, 4th gen), I decided to mainly use that one instead. However, I encountered some weird problems, too.
When I tried to synchronize new entries, I would get the same text box saying “Loading entries”. At first it seemed as if nothing wrong happened, but the app wouldn´t stop synchronizing, even after more than 24 hours and despite closing the app or rebooting the device. Threfore, I tried to back up the iPad. Epicollect data was included (theoretically), but, when I tried to retrieve it, branches were empty.
I am starting to suspect all this has to do with our project having way too many entries, although I am not sure. Would deleting already-synchronized entries help? Do you have any other tips I could follow?

Thank you very much.

Have you tried from a clean state?

Re-install the app, add 1 entry and then sync.

Does it work as expected?

It appears that no additional details have been provided regarding the current thread.

In the absence of further information, we are unable to proceed with the discussion.

If you have any additional details to share or questions to ask, please feel free to start a new thread.

Thank you for your understanding.