Epicollect5 not saving entries

One if our Epicollect5 project* users has been experiencing errors when trying to save their entries. Their problem description is as follows “Epicollect5 software wasn’t letting me save my readings and I had to resort to quitting each reading, which would save the entry. would then download all four entries when I was back in the house.
The software was updated a couple of weeks ago. The same problem continues but there is a new wrinkle. When user tries to upload entries, they get a list of tabs with a red one at the top that says, “Check Entries”, when I press that, I go to a list of about ten old entries ticked red. Checking a couple and they seemed fine. However, when they try to upload data, nothing happens”

Grateful for any pointers on what might be needed to fix the uploads. I have tried to replicate the errors on my smartphone but no joy.

Thank you

When encountering entries with errors, you have a couple of options for resolution:

Viewing Errors Individually:

By tapping on a specific entry, you can view the details of the associated error. This allows you to identify and address the issue on a case-by-case basis, see →

Filtering Entries with Errors:

Navigate back to the list of entries and apply a filter to display only those entries with errors. This consolidated view provides a quick overview of all problematic entries, making it easier to manage corrections.
After identifying and correcting the errors in the entries, be sure to save your changes. Following this, you can attempt to upload the corrected entries once again, see →

For a more comprehensive approach, consider performing a full re-sync. This will synchronize all entries, including those that were previously unsuccessful, and ensure that the most up-to-date data is successfully uploaded, see →

If you have any further questions or encounter challenges during this process, feel free to seek additional assistance.

I have two entries that have a message, “No data attribute found in json structure.”
What does this mean?

That is a generic upload error, have you tried a full re-sync? →

I resynced. Can I delete all the entries on my phone on the assumption that they have all been uploaded, even the ones I couldn’t upload before? I had 659 total with 20 I was having trouble uploading.

You can check the entries correctly uploaded by using the dataviewer

You can try to enter the entries not uploading from the device by manually adding the data using the web application

Do not delete anything on the device until you are 100% happy with what you have on the server.

It appears that no additional details have been provided regarding the current thread.

In the absence of further information, we are unable to proceed with the discussion.

If you have any additional details to share or questions to ask, please feel free to start a new thread.

Thank you for your understanding.