Error del servidor, intentalo de nuevo mas tarde

Hola, de manera repentina a partir del dia 26 de febrero, al momento de sincronizar las entradas en los dispositivos móviles tablets marca LENOVO, sale un error que dice, “Error del servidor, inténtalo de nuevo mas tarde. Si el problema persiste, póngase en contacto con el administrador del servidor”

Dicho error sucede solo en las tablets, ya que los mismos proyectos los uso en celulares y en ellos funcionan correctamente.

son 14 tables las que les aparece el error simultaneamente.

Could you kindly share an example, possibly with screenshots, illustrating the issue you’re encountering? Moreover, please provide the name of the project(s) affected by the issue.

Your insights will greatly assist in understanding and resolving the problem.

Thank you.

When encountering entries with errors, you have a couple of options for resolution:

Viewing Errors Individually:

By tapping on a specific entry, you can view the details of the associated error. This allows you to identify and address the issue on a case-by-case basis, see →

Filtering Entries with Errors:

Navigate back to the list of entries and apply a filter to display only those entries with errors. This consolidated view provides a quick overview of all problematic entries, making it easier to manage corrections.
After identifying and correcting the errors in the entries, be sure to save your changes. Following this, you can attempt to upload the corrected entries once again, see →

For a more comprehensive approach, consider performing a full re-sync. This will synchronize all entries, including those that were previously unsuccessful, and ensure that the most up-to-date data is successfully uploaded, see →

If you have any further questions or encounter challenges during this process, feel free to seek additional assistance.

Uploading: WhatsApp Image 2024-03-06 at 10.28.12.jpeg…

That is not very informative we are afraid.

It’s possible that your current internet connection speed could be impacting your ability to upload a screenshot. Have you considered trying a different connection to see if the issue persists?

Sometimes switching to a different network or using a wired connection can help improve upload speeds.

Hello. I’ve been having a similar problem: I tried to synchornize (or upload) some entries on two proyects (Epicollect5 - SALMONELLA INTA and Epicollect5 - SALMONELLA UNAB), but the same message appears: “Error del servidor. Inténtelo más tarde” (“Server error. Try again later”).

I tried with desynchronization, but when I go back to upload all entries again, it stops around 860 (of 1256) and then the message pops up again.

I also updated the app to the latest version (5.2.0), but the result is the same.
All of these steps have been testes with different internet sources (WiFi and mobile) in my tablet (if there is a way of putting all of these entries in another device and upload them from there, I’d be happy to read about how to do it). I haven’t tried uninstall/reinstall because I’m afraid of losing the data in the process.

I’ll share a picture of the message.


To better troubleshoot the situation, could you kindly run a speed test using

on your mobile device and share the results with us?

This information will help us determine if the issue might be related to internet speed or other factors.

Also, what day(s) did you try to perform the upload?
This information will help us when looking at our logs.

Thank you.

@Raul_Guevara Moreover, have you tried to upload again?

if the upload stops at 860/1256, 860 entries should be synced, can you double-check?

The next upload will start at entry 861/1256 since the previous 860 entries were synced already.

I will run the speed test when I reach the City (right now I’m on terrain, surrounded by mountains, so the speed test will not represent the average internet speed at which I usually synchornize and upload the entries). On this location, the results mark a speed of 12 mbps. (I’ll leave the screenshot), but I tend to use WiFi at home to upload, which should surpass this numbers greatly (usually hovers around 150 to 200 mbps.), so I doubt bandwith or Internet speed to be the issue.

The days I tried to upload were tuesday, wednesday and today (march 5th, 6th and 7th).

Also, when I try to upload again (after the ~860 mark failure) and press “upload data”, it does show “0/410” but then goes straight to “error del servidor. Intente más tarde” (I’ll add the screenshot). So it “starts” from where it left off, but doesn’t upload at all.

I’m experiencing the same issue when I try to upload data from my Android tablet. If I try it with my phone, it’s working fine (same internet connection). I would guess it’s more a device related problem.

@Max_Voss @Raul_Guevara @AndresHerrera

Could you please share the model and Android version of your devices?

@Max_Voss @Raul_Guevara @AndresHerrera

Could you all try to update the Android Webview on the devices with issues?

Update Android System Webview

Step 1. Launch the Settings app.

Step 2. Tap Apps.

Step 3. Select Android System WebView.

Step 4. Tap App details in store.

Step 5. Tap Update. Then, restart the device.

Update Chrome

Repeat the same steps to update Chrome.

Step 1. Launch the Settings app.

Step 2. Tap Apps.

Step 3. Select Chrome.

Step 4. Tap App details in store.

Step 5. Tap Update. Then restart the device.

@Raul_Guevara entry 410 might have some issues.

To troubleshoot the upload issue you’re experiencing, please follow these steps:

  1. Navigate to your entries list on the device.

  2. Sort the entries by “Oldest” so that entry 1 of 410 (the first one picked by the upload script) is displayed at the top.

  3. Tap on the first entry to review its content for any anomalies or unexpected behaviour.

  4. If everything appears normal, proceed to manually back up the answers and export any associated media files. You could enter the data directly to Epicollect5 via the web application.

  5. Once the backup is complete, delete the first entry and attempt to upload again.

  6. Since your project is public, try to upload both when logged in and when logged out.

  7. Sometimes rebooting fixes weird bugs.

If the issue persists after following these steps, please report it again, and we’ll explore further troubleshooting options, including repeating these steps with additional entries.

Thank you

Mine is Samsung Galaxy Tab A6 (modelo no. SM-T280).

  • There is no way of updating Android system webview on this tablet.

  • the entry from May 10th 2022 is the first of the non uploaded group. I checked for problems, but there was none.

  • I still have the last solution to try, but i need to know if by “manual backup” you mean to literally write the info on Excel or some sheet, or is there a way in the app to backup the entries (since when pressing “download”, the same server error message appears)

  • I think it’s worth mentioning that before all of this “server error” problem, every entry up until december of 2023 was successfully uploaded then. So the fact that this May 10th 2022 entry is the limit between uploaded and not uploaded is a recent issue, probably related to the unsynchronizing and reuploading step mentioned as the first solution in this message chain.

The Galaxy Tab A (2016) SM-T280 is a 2016 device with a very old version of Android, which might be the cause of all the issues you are having.
From our User Guide

We support phones and tablets on Android 5.1 and onwards. However, starting with Android 5.0, the webview was moved to a separate application that can be updated independently of Android.
This means that most Android 5.0+ devices are going to be running a modern version of Chromium.
However, there is still a subset of Android devices that are unable to have their webview updated.
These webviews are typically stuck at the available version when the device initially shipped, making Epicollect5 incompatible.

Having said that, removing entries one by one until they finally can get uploaded is still worth a try. Moreover, try to install/update the Chrome browser.

To answer your question about backing up entries, you are correct to assume you will need to write the info into Excel (or the Epicollect5 web) directly as currently, the Epicollect5 mobile app does not feature a bulk export of data we are afraid.

A final consideration: the Epicollect5 team needs to address another important aspect: due to the increasing number of issues arising from older devices running outdated versions of Android, we must raise the minimum Android version supported by our apps to Android 10, as recommended by Google.
Consequently, we’ll continue to offer the old app with the designation “not officially supported.”
This approach empowers users to decide for themselves whether it’s reliable to use Epicollect5 on their devices.

I’ll try the manual method then, but the form of both proyects include items like “location” (via GPS), “time” and “date” of sampling (via the tablet’s internal clock) that cannot be set manually. So if I do the transcription, these three values will be lost and replaced with my current location, time and date (meaning I will have a substantial amount of data with the same GPS location, and a time and date that do not correspond with the moment when the samples were taken).

I still have two questions:

  • why or when did this incompatibility began? If there is an exact date at which epicollect5 was known to no longer be supported by some devices, I’d like to ask you for it.

  • why, if it is incompatible by now, it still can synchornize some entries and some don’t, with no particular characteristic defining either of them (since I double-checked for errors and there were none)?

Thanks for your support so far. I wish we reach some way of fixing this.

Could you please elaborate on

“but the form of both projects include items like “location” (via GPS), “time” and “date” of sampling (via the tablet’s internal clock) that cannot be set manually.”

If you enter data manually into the Epicollect5 web app using a desktop browser, you can enter any value you want. If you copy the data manually from your device into Excel, you can set any value you want.

  • why or when did this incompatibility began? If there is an exact date at which epicollect5 was known to no longer be supported by some devices, I’d like to ask you for it.

We’ve been compelled to update our app with the latest libraries by Google and Apple. While these updates bring enhancements, they aren’t always fully compatible with older devices. Consequently, we occasionally encounter issues post-update, as it’s impractical for us to test on every device in the market. We do have an exact date but, we can assume any of the 2023 releases might have introduced issues we were not aware of.

why, if it is incompatible by now, it still can synchornize some entries and some don’t, with no particular characteristic defining either of them (since I double-checked for errors and there were none)?

Unfortunately, we don’t have access to your specific device, making it challenging to replicate the exact circumstances and errors you’re encountering. However, we did clone your project and successfully synchronized 2000 dummy entries without encountering any issues →

@Raul_Guevara one more thing, your projects on the web server do have ~1200/1300 entries synced by looking at our projects.

  • It appears that all the 2022 entries have been successfully synchronized. Despite any errors encountered during the process, it’s essential to verify that the data is accurately reflected.

  • To confirm, please check if the entries on your device match the 1256 entries stored on the server for both projects. This close correspondence suggests successful synchronization.

  • When you unsync entries on the mobile apps, it essentially clears a flag. This action allows you to upload the locally saved entries again.
    However, it’s crucial to note that unsyncing does not impact the entries stored on the server. They remain untouched.

It appears that no additional details have been provided regarding the current thread.

In the absence of further information, we are unable to proceed with the discussion.

If you have any additional details to share or questions to ask, please feel free to start a new thread.

Thank you for your understanding.