Error while uploading image files

I’m experiencing issues during the saving of a single branch and also when uploading image files from my mobile device to the server (iOS version 12.5.2).
Are these common issues?


have you tried to re-install the app?

If the issue persists, please provide a way to reproduce it so we can look into it. Thank you :slight_smile:

1 Like

One of my users has a similar problem. The save function is acting strange. When reaching the screen to save to the device, the Save button is a faded green instead of bright green. Clicking it does not seem to do anything. The Next> button is not active nor is the Prev < button. Only Quit works but it asks to save which does not seem to work either. When the app is closed and reopened, the record has clearly been saved. At that point it is possible to upload the data.

Like Davide, she is unable to upload a photo. I would show you screen shots but I get this message trying to upload a very small jpeg.


The first error message says “Server error, please try again later. If the problem persists, please contact the server administrator”

This message is immediately covered by this message:

“Some entries could be uploaded, please check for errors”

This is on an IPhone 11 running IOS 14.4.2

Her version of epicollect was installed about this time last year. I will ask her to do a reinstall to see if that helps. You can look at the form at the project MIDGE WINDOW SURVEY.


Oh, the upload to this post did work. INot to be confused with the app on the IPhone, I am talking about my post of a couple of minutes ago. When I tried to insert an image in my post, I got and error instead. This is the error that was inserted in to my post.


Lets try that again. Just concatenate the two lines and you should see what I see when I try to upload an image…



I’ve had two users recently experience the same issue trying to upload photos. Both are using iPhones; both did not use the app for a few days prior to having the issue. Our form collects up to 4 photos per entry. One lost 4 entries (12 photos); the other lost 6 entries (19 photos). I’ve spoken with the second user, whose provided information about the problem that I haven’t seen listed here.

First, we tried to extract the photos using the entry edit / select photo / save to local photos technique. None of the photos were visible within the app.

Second, photos from previous entries which had been visible from within the app were now also not visible.

She has since reinstalled the app and photo uploads are working now.

We cannot recreate the situation, so I don’t expect any action, but I thought maybe this additional information might trigger a thought or two.

Does it happen the users updated iOS before facing the issue?

Beware migrating to a new iPhone!

Okay, this project only has 15 users so to have 3 of them have problems was worrisome. However, comparing stories from them, it turns out all three migrated to a new iPhone. It sounds like iPhone migration tries to migrate apps and data. With EpiCollect it appeared to work, but I’m guessing the photo data was corrupted.

All three are working well since reinstalling (without the keep data option).

I’m not sure why this didn’t come out when I originally asked them each about any changes that might pertain to the problem.

Anyway, ios users should consider deleting / reinstalling EpiCollect rather than migration when getting a new device.

Thanks for your attention.

Good to know. We would recommend uploading data and media before migrating.